miércoles, julio 01, 2009

Alcatel One Touch X060S en Linux

Nota personal por si se me olvida:

"No se te ocurra fiarte de lo que dice wvdialconf"

A mi me detecta el módem en /dev/ttyUSB1 pero al intentar marcar me cuelga el bus usb. Configurándolo con /dev/ttyUSB3 ha funcionado.

Resumiendo: - Instalar usb_modeswitch

- Editar /etc/usb_modeswitch añadiendo:
DefaultVendor=0x1bbb
DefaultProduct=0xf000
TargetVendor=0x1bbb
TargetProduct=0x0000
TargetClass=0x0
DetachStorageOnly=0
HuaweiMode=0
SierraMode=0
SonyMode=0
MessageEndpoint=0x1
MessageContent="55534243123456788000000080000
606f50402527000000000000000000000"
Interface=0x0

- Editar /etc/wvdial.conf poniendo:
[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = AT+CGDCONT=1,"IP","gprs-service.com"
Password = 1234
Phone = *99***1#
Modem Type = Analog Modem
Stupid Mode = 1
Baud = 460800
Modem = /dev/ttyUSB3
ISDN = 0
Username = 1234

- Al pinchar la llave:

# usb_modeswitch
# modprobe usbserial vendor=0x1bbb product=0x0000

- Si esto no crea los dispositivos, probar a arrancar pasándole al kernel:
usbserial.vendor=0x1bbb usbserial.product=0x0000

- wvdial

- Profit!

Etiquetas: , ,

2 Comments:

Blogger bevot said...

Tú eres por lo menos...de Bolaños..
peazo friki!!!!

9:37 p. m.  
Blogger Herzeleid said...

¡Jo! Me han vuelto a conocer =)

9:09 a. m.  

Publicar un comentario

Links to this post:

Crear un enlace

<< Home

Licencia de Creative Commons
Esta obra está bajo una licencia Creative Commons.

Powered by Blogger